Color fields on an invoice are converted to black during Interpret
Article # 3030360 - Page views: 66
Issue
When an invoice image contains colored (or gray) blocks, the system converts the entire block to black and the data is lost.
Cause
The threshold for determining whether a pixel should be black or white is too high in this instance, so the pixel is set to black.
Solution
There are two solutions to this issue.
- Contact the supplier for whom the invoice is provided and ask that the colored/gray shading on the invoice be removed to allow the automated process to take place and payments to be issued in a timely manner.
- Change the threshold for which pixel is recognized as black. The PDFThresholdMethod can be changed to try to improve the image conversion. The setting is found in the [Options] section of the EIGLOBAL.ini file and the valid values are shown below.
- 0 - Local contrast (Bernsen)
- 1 - Iterative selection
- 2 - Iterative selection without bin 0
- 3 - Local adaptive thresholding (Niblack)
- 4 - Otsu method
- 5 - A combination of 0 and 1
- 6 - A combination of 1 and 3
- 7 - Simplified image statistics (default)
Each value can be tested in your solution by updating the parameter in the EIGLOBAL file, saving the file, then restarting Interpret to reprocess the original image. Should the image not be suitable for conversion with any option, the supplier must be contacted to update the invoice layout.
Level of Complexity
High
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
INVOICES | ALL | ALL | ALL | ALL |