Database cannot be opened (13521,0,0). Provider cannot be found.
Issue
Error when attempting to start INVOICES modules:
"Database cannot be opened (13521,0,0)
Provider cannot be found. It may not be properly installed"
Cause
The MS OLE DB Driver for SQL server is not installed. This driver is required in order to connect using the TLS 1.2 protocol.
NOTE: Invoices only supports version 18 of this driver, newer versions will not resolve the connection error.
Solution
Install the "MS OLE DB Driver for SQL server" on the computer(s) where the error is shown.
Note that you need to install the 64-bit version of the driver if you use a 64-bit operating system.
The following configuration changes may also be required:
Add the entry "MSOLEDBSQL=1" to the EIGLOBAL.ini file under the [Database] section.
Adjust to "SecurityProtocolType=4" under the [General] section in COLLECTOR.ini file.
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
ReadSoft INVOICES | 6.0.2 and newer | |||
ReadSoft Collector | 65.0.4 and newer |