Skip to main content
Kofax

Database maintenance failure produces several error dialogs

Article # 3036519 - Page views: 30

Issue

A database maintenance plan is run in the Invoices application, but the plan fails to complete and generates error dialogs with messages such as the examples below:

"ReadSoft.INVOICES.DBMaintenance"
An error occured when running
select docid, createtime, defname, status, queues...
Connection failure

After acknowledging the error message, another dialog is displayed:

Unhandled exception has occurred in a component in your application.
If you click Continue,. the application will ignore this error and attempt to continue.
Cannot write to a closed TextWriter

Cause

The network connection between the computer running database maintenance and the database server is unstable; i.e., a connection failure has occurred between the two computers. The maintenance plan will not be able to continue due to the connection failure.

Solution

1. Terminate the Manager process (eimngr.exe) via Windows Task Manager.

2. Start the Invoices Manager and unlock the database.

3. If the same issue occurs after restarting the maintenance plan, then repeat step 1 and 2 from a different computer (such as the Invoices server). In order for database maintenance to complete successfully, the network connection to the database server must be stable.

Level of Complexity 

Moderate

Applies to  

Product Version Build Environment Hardware
ReadSoft INVOICES All      

 

  • Was this article helpful?