INVOICES services failing to start error message 1064
Issue
It is not possible to start INVOICES PMService
The error message: "Error 1064: An exception occurred in the service when handling the control request" is displayed.
Cause
This errors can appear when Invoices has been upgraded from a previous version, when a change in the database is made (for example is moved to a new server) or if it is a fresh installation.
The possible causes are:
1- The most common reason is that if the server name has changed, even after upgrade invoices database the old name remains in the services configuration table in the database (dbo.servicestatus)
2- By defect INVOICES encrypts the password the first time a module is started and sets EncryptedPassword to 1 to indicate that the value in the Password setting has been encrypted. However due to a problem during the upgrade, the password is not encrypted, so this is an inconsistency.
3- The user account that has been set in the PMServices configuration in Windows Services has not the appropriate privileges.
Solution
Cause 1: old name remains in the database (dbo.servicestatus)
Solution: Manually change the server name in the database:
- 1- delete instances and services (all) and close manager
- 2- Make a backup of the Invoices database
- 3- open SQL management studio and locate the dbo.servicestatus table in the Invoices database.
- 4- delete the name of the server that appears there.
- 5- Open manager, run a database maintenance
- 6- create the instances and services again and test.
Cause 2: wrong value for EncryptedPassword
In the eiglobal.ini the flag UseEncryptedPassword is set to 0? if not, please set EncryptedPassword=0 save and test again.
Please,check the article reference to see how to locate the eiglobal.ini file used by Invoices:
Cause 3: lack of permissions of the services account.
Check the user account which has been set in the PMservices configuration in Windows (services.msc).
By default, the Local System account is used for Interpret and Transfer services. However, this account does not have the necessary privileges to connect to the other computers in your Kofax ReadSoft Invoices installation (such as the one where your scanned images are stored).Before Kofax ReadSoft Invoices services can be enabled, they must be configured with an administrator account that has domain administrative privileges on all of the computers in the system where services are configured and run.
Level of Complexity
High
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Invoices | All | All |
References
ReadSoft: How to locate the eilocal.ini and eiglobal.ini files used by INVOICES - https://knowledge.kofax.com/ReadSoft/Troubleshooting/ReadSoft_How_to_locate_the_eilocalini_and_eiglobalini_files_used_by_INVOICES