Skip to main content
Kofax

Cannot run robots when upgrading from 10.7.0.x to 10.7.0.x or v11 (after backup restore)

3024600

Question / Problem: 

When you take a backup from v10.7.0.2 and restore it to a 10.7.0.3 you won't be able to run robots of previous versions You get an error saying "No available servers to run the robot with version <robot version>" Note: these robots were running fine on v10.7.0.2 This only seem to happen when the robots are brought through backup/restore.

Answer / Solution: 

This is a Bug: Bug 1457810: Cannot run robots when upgrading from 10.7.0.x to 10.7.0.x or v11 (after backup restore)

It was reported in 10.7.0.3. 

 

Workaround:

For CRE setups only:

when upgrading, restoring a backup from a previous version (even a previous fix pack version) you have to manually bump the "Threshold RoboServer version" if you no longer have RoboServers of the previous version running in a cluster. In your case, please go to "Cluster Settings" -> "General" and change the "Threshold RoboServer version"

For KCU setups we can't do this. "Threshold RoboServer" is disabled. 

Applies to:  

Product Version
Kofax RPA 10.7>