"Could not connect to the Automation Device acquired using <machineName>" Errors
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Issue
Error when attempting to connect to a device: "Could not connect to the Automation Device acquired using DAMachine, Error calling Desktop Automation service: Caught exception. Error getaddrinfo ENOTFOUND DAMachine DAMachine: 49998 at ernoException (dns.js:50:10) at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:92:26)"
Cause
Name resolution issue after device operating system is upgraded.
Solution
- Reconfigure DAS to use single-user mode and specify the IP address for the Host field. Restart DAS.
- From Design Studio, recreated the device using a direct connection, not Management Console.
- Retest to verify successful connection.
You can then create a device mapping in Management Console after finished development in DS using single user mode. Change DAS back to Management Console mode access and restart.
For additional information, refer to the User's Guide for your specific version of RPA (link below).
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
RPA |
10.x 11.x |
Article # 3046756