How to Log into a Citrix Application Using Device Automation
Symptom:
When using Device Automation to log into a Citrix application, the Citrix application may time out after Device Automation clicks the log in button.
Cause:
The 3rd party software used for the RDP connections in Device Automation is not behaving properly when clicking the log in button.
Resolution:
Add a registry key on the machine with the Device Automation Service with the values specified below:
Location: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432node\Citrix\ICA Client
Name: VdLoadUnLoadTimeOut
Value: 30