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Troubleshooting "Could not connect to the platform database (JNDI resource 'jdbc/kapow/platform')" error

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Summary

This Knowledgebase article details the main root causes for the error "Could not connect to the platform database (JNDI resource  'jdbc/kapow/platform')". This applies to Management Consoles deployed into standalone Tomcat.

More Information

Symptoms

After deploying Management Console in Tomcat, the web interface doesn't load. The browser shows one (or more) of the following errors:

  • Spring subsystem failed to load
  • Error 500
  • Error 404

Also, in the Tomcat logs, there are multiple entries with the same error

"Could not connect to the platform database (JNDI resource  'jdbc/kapow/platform')"

Cause

This error is caused by the lack of communication with the platform database. This can be caused by various reasons detailed below

Resolution

To troubleshoot this issue, the database configuration is needed. This can be found in the Management Console XML context file normally located under Tomcat's /conf/Catalina/localhost folder. This file has to be created by the user who is deploying the Management Console (see the instructions in the Admin Guide for more information).

The table below lists the main possible causes why Tomcat is not able to create the content in the platform database, even when Management Console XML context file exists:

To Check How
is the JDBC driver provided? check the type of database being used (in the Management Console XML context file) and make sure the corresponding driver is uploaded in either:
  • Tomcat lib folder
    or
  • in Tomcat under /webapps/ManagementConsole/WEB-INF/lib
can the Tomcat machine reach the Database machine? ping and telnet using the machine name/IP and port specified in the Management Console XML context file
do the credentials work? check by logging in to the database using its own Management Tools
is the url connection string correct?

make sure the connection string is correct for the database type.

E.g. are you using a connection string for a MS SQL server meant for SQL authentication and providing Windows credentials (not SQL)?

does the database exist? check in the Management Tools of your database server. Management Console needs to have the database created, it will not create it. Also, the case has to mactch.
does the user have rights to create tables? if the database is empty, the Management Console will create the tables as long as the user provided has the rights. The user credentials are the ones in Management Console XML context file (keep in mind that when using MS SQL with a connection url that uses windows authentication, the credentials that Tomcat will use are the credentials of the user running the Tomcat process, regardless if they are the same as the ones in Management Console XML context file).

If neither of the options above help, please contact Kofax Technical Support.