Skip to main content
Kofax

Kofax TotalAgility - After upgrading KTA capture and/or system forms display blank

After upgrading KTA capture and/or system forms display blank at runtime.  This behaviour can be further characterised by forms not rendering, and just a blank white screen with no errors on screen.  If you create a new form, it loads successfully, however none of the existing forms load.

 

Applies to

Kofax TotalAgility 7.0.2 or above

Behaviour

After upgrading KTA capture and/or system forms display blank at runtime.  This behaviour can be further characterised by forms not rendering, and just a blank white screen with no errors on scree .  If you create a new form, it loads successfully, however none of the existing forms load.

Resolution

Were any errors reported during the upgrade procedure?  TotalAgility creates a log files called Kofax TotalAgilityInstallErrorLog.txt and CEBPMDatabaseErrorLog.txt on your desktop.  If any errors occurred, it can prevent the Agility.server.upgrade.exe from completing.   This can impact forms and other artefacts as the platform is only partially upgraded.

If the Platform DBs were upgraded manually,  was the Agility.server.upgrade.exe manually executed via agility bin folder as per the KofaxTotalAgilityInstallationGuide? If so, did it complete without errors in the application event log or desktop? 

To alleviate,  (re)run the agility.server.upgrade.exe.  Instructions are found in the “Upgrade databases manually” KofaxTotalAgilityInstallationGuide_EN:

In addition, stop IIS, clear the deployed forms folder (C:\ProgramData\Kofax\TotalAgility\Deployed) and restart IIS.

If problem persists, raise a Kofax case in the support portal with above information and any additional like Browser F12 console errors and browser HAR traces to review.

  • Was this article helpful?