Skip to main content
Kofax

Configuration Utility - custom binding coreservice

3018429

Question / Problem: 

When using the Configuration Utility to change an  environment from HTTP with Windows to HTTPS with Windows, the CustomBinding_CoreService is incorrectly modified by the utility.

Answer / Solution: 

The section <binding name="CustomBinding_CoreService"... changes from its default below:

<binding name="CustomBinding_CoreService" openTimeout="00:10:00" closeTimeout="00:10:00" sendTimeout="00:10:00" receiveTimeout="00:10:00">
<binaryMessageEncoding>
<readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" />
</binaryMessageEncoding>
<!--
<httpTransport authenticationScheme="Negotiate" for http with windows authentication
<httpsTransport authenticationScheme="Anonymous" for https with None authentication 
-->
<httpTransport authenticationScheme="Negotiate" allowCookies="true" maxBufferSize="2147483647" maxReceivedMessageSize="2147483647" maxBufferPoolSize="524288" />
</binding>

to the following, without any of the attributes, and with the authentication set to Anonymous instead of Negotiate as expected.:

<binding name="CustomBinding_CoreService" openTimeout="00:10:00" closeTimeout="00:10:00" sendTimeout="00:10:00" receiveTimeout="00:10:00">
<binaryMessageEncoding>
<readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" />
</binaryMessageEncoding>
<!--
<httpTransport authenticationScheme="Negotiate" for http with windows authentication
<httpsTransport authenticationScheme="Anonymous" for https with None authentication 
-->
<httpsTransport authenticationScheme="Anonymous" />
</binding>

Also, when trying to revert back to HTTP with windows, instead of getting back to the original default settings, we got the following:

<binding name="CustomBinding_CoreService" openTimeout="00:10:00" closeTimeout="00:10:00" sendTimeout="00:10:00" receiveTimeout="00:10:00">
<binaryMessageEncoding>
<readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" />
</binaryMessageEncoding>
<!--
<httpTransport authenticationScheme="Negotiate" for http with windows authentication
<httpsTransport authenticationScheme="Anonymous" for https with None authentication 
-->
<httpTransport authenticationScheme="Anonymous" />
</binding>

Apparently this has been fixed in KTA 7.6

Applies to:  

Product Version

KTA

7.4

7.5