Skip to main content
Kofax

Kofax TotalAgility - "Invalid Session ID" error when importing/exporting a package in OPMT

Applies to

  • Kofax TotalAgility v7.5
  • Kofax TotalAgility v7.6
  • Kofax TotalAgility v7.7

Scenario

When importing/exporting a package into KTA OPMT, an error Invalid Session ID - Your session is invalid because it may have timed out. Log on again is thrown

clipboard_eaae69fb0277ba79130bfdafe8a3f403d.png

Cause

This error can occur when there are conflicting TotalAgilityHostNameLive and TotalAgilityHostNameDev settings configured in the web.config and Agility.Server.StreamingService.exe.config configuration files.  Most likely caused by human error when modifying the files.

For example, the web.config has the below settings configured

   <add key="TotalAgilityHostNameLive" value="KofaxOPMT" />
   <add key="TotalAgilityHostNameDev" value="KofaxOPMT" />

Below is configured in the Agility.Server.StreamingService.exe.config file

   <add key="TotalAgilityHostNameLive" value="ServerName" />
   <add key="TotalAgilityHostNameDev" value="ServerName" />

These values need to be consistent in both file.

Note:  We recommend using the KTA configuration utility in order to change these settings.  This way we can ensure both files are consistent.

  • Was this article helpful?