TotalAgility POP3 Import Source Creating 2 Jobs From Same Email
Issue
A Message Connector Import Source is used with 2 different Message Connectors and they are polling the same POP3 mailbox. Sometimes 2 jobs are created from the same email message. Is there a way to prevent the duplicate job?
Cause
This is a possible scenario when 2 Message Connectors are polling the same mailbox.
Solution
The Import Source configuration for the POP3 email protocol does not have any options for preventing this behavior. There is a "Mode" setting for some Import Source configurations, such as IMAP and MS Graph, however, there are even some IMAP servers that do not support this option. The Mode setting contains an option for 'Multiple Instance' and 'Single Instance,' which dictates whether multiple sources can poll the same message. Here is a screenshot of the setting.
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
KTA | All |
References
Add any references to other internal or external articles
Article # 3046669