Using a Load Balancer and getting an unable to log into server B 404 error
Article # 3042606 - Page views: 13
Issue
Using a Load Balancer, why am I getting an unable to log into server B 404 error? Both servers are configured identically.
Server "A" works while server "B" did not.
Cause
The Load Balancer was incorrectly set up.
Solution
Got a HAR file for the working server "A" and the non-working server "B". A comparison of the HAR files showed that server "B" had the following:
- A mixture of URLs to both server "A" and "B". The Load Balancer needed to be changed so all URLs were for server "B".
- The URLs for server "A" was http, whereas server "B" was set to https. Changing to http resolved the issue.
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
KTA | 7.x |
Article # 3042606