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Active Directory synchronization does not populate a users password

Article # 3035456 - Page views: 18

Issue

After executing a SYSTEM Active Directory Synchronization (AD Sync) job, resources were created without passwords.  This caused the error Invalid Username or Password when logging in to Kofax TotalAgility (KTA).

 

Cause

When using the AD Sync process to pull Windows user accounts into KTA from Active Directory, the user's password is not passed through.  Therefore, it will not be possible to log in to KTA using manual authentication.

 

Solution

This is by design and it is expected that Windows authentication will be configured for logging into KTA for Windows users, not a login screen. Since the matching KTA account does not have a password, the login will fail when the user tries to use their AD credentials. The manual login screen should only be used for user accounts that are created in KTA as 'KTA only' user accounts.

Using Windows authentication for logging in will work for the AD Sync accounts because they have already been authenticated when logging into the computer workstation.

 

Level of Complexity 

Moderate

 

Applies to  

Product Version Build Environment Hardware
Kofax TotalAgility ALL      

 

 

Article # 3035456
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