Skip to main content
Kofax

Email Content is causing Document Conversion to fail with exit code 1 (Cat=Error, Obj=unknown, Mod=M_Unknown)

Article # 3041326 - Page views: 190

Issue

In this scenario, email was imported to KTA and failure happens at Document Conversion Activity Node in the process flow.

  • Email was imported to KTA via KIC.
  • In the import setting, there is "Create document from body" option selected.
  • Document Conversion failure has only this error: “Document Conversion failed with exit code 1 (Cat=Error, Obj=unknown, Mod=M_Unknown)“

 

Cause

In this scenario, it was found that there is a logo causing the failure. 

  • When the logo was removed from the email content then such email imported is fine (even it has other logo and images).

Note: If your issue is something else in the email content, you can try the different values combination (refer to solution) otherwise please log the support case and provide as much details as possible to seek help.

 

Solution

1. Set AllowedErrors = 4224 under [PDF2PDFA] section in C:\Program Files (x86)\Kofax\Document Converter\bin\KFXConverter\KFXConverter.ini

  • The default value is 128 for AllowedErrors.
  • As per ini comments, the valid values are 4,8,16,32,128,512,4096,16384,32768,65536.
  • Setting 4224 is valid as it is the same value as 128 + 4096.
  • AllowedErrors is used only for ignoring the error code as mentioned in the INI file.
  • 4096 = allow normalizing corrupt input document

2. After saving the ini file, then restarted TS, MC, CW services (in that order)

  • TS - Windows Service for Kofax Transformation Server.
  • MC - Windows Service for Kofax Message Connector.
  • CW - Windows Service for Kofax TotalAgility Core Worker.

3. Re-process again and verify.

  • For those suspended jobs, restart at the Document Conversion Activity Node.
  • To re-run the message for re-import, go to Message Connector Monitor, at the processed status, find the message (email) and click re-run button.
  • For testing, re-send email to the email account which KTA/KIC is polling to import into KTA process.

Note:

  • This was tested in KTA 7.9, it should be workable for other versions if the above can be done.
  • When there is conversion error, sometimes we could also check info at e.g. C:\ProgramData\Kofax\KFXConverter\KFXConverter.log

Level of Complexity 

Easy

 

Applies to  

Product Version Build Environment Hardware
KTA 7.X 
(Tested on 7.9)
     

References

N.A.

 

Article # 3041326
  • Was this article helpful?