Failed to re-run process error produced from Transformation Server
Issue
The following error is observed in the Microsoft | Event | Application log on the Transformation Server:
"Failed to re-run process: Kofax.CEBPM.CPUServer.Common.Exceptions.CpuServerException: Failed to start service hosting process (8492). The process exited on start (or crashed).
at Kofax.CEBPM.CPUServer.Core.ResourceServer.ProcessPools.ServiceProcess`1.ConnectToProcessService(ProcessInformation`1 procInfo, EventWaitHandle processInitializedEvent)
at Kofax.CEBPM.CPUServer.Core.ResourceServer.ProcessPools.ServiceProcess`1.CreateNewProcessAndConnect()
at Kofax.CEBPM.CPUServer.Core.ResourceServer.ProcessPools.ServiceProcess`1.RunTaskExecution[T](Func`1 serviceCall)"
Cause
This error can be logged when there are issues restarting the Transformation service. In some cases, there maybe more instances of ExtractionProcess.exe (a child process of the service) than should be running based on the MaxProcessingSlotsNumber defined in the 'C:\Program Files\Kofax\TotalAgility\Transformation Server\Kofax.CEBPM.CPUServer.ServiceHost.exe.config' file.
This seems to mean that there are instances of ExtractionProcess.exe that that got stuck and the service process was not able to close them.
Solution
1. Go to Windows Services and kill the Kofax Transformation Server process.
2. Go to Task manager and kill the following processes:
Kofax.CEBPM.ProcessingService.Host.exe
Kofax.CEBPM.DocumentConversionService.Host.exe
Kofax.CEBPM.CPUServer.ServiceHost.exe
3. Restart the Kofax Transformation Server process.
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
KTA | All |
References
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