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One or more document fields does not exist

Article # 3038590 - Page views: 71

Issue

When trying to update or access a document field the error below is thrown:

Error Description  : One or more document fields does not exist

 

Cause

The error is self explanatory in that it clearly states that the field we are trying to access does not exist for this document instance.

There could be a few reasons for this error:

1 - The document is not classified.

If the document is not classified, it will not have any fields defined, so any attempt to access a specific field will give this error.

2 - The document is classified to another document type that does not contain the same fields

The document could have classified to a type the developer was not expecting and this new type might have different fields to the ones we are trying to update.

3 - The document seems to be classified to the same document type but the fields are different.

This is the most uncommon scenario but it has occasionally been reported when customers have created different Extraction groups(EG) with document type names that already exist on another EG.

 

Solution

Scenarios 1 and 2 can be resolved by making sure the documents are correctly classified.

To avoid scenario 3, customers need to make sure not to duplicate document type names across different extraction groups.

 

Level of Complexity 

Easy

 

Applies to  

Product Version Build Environment Hardware
KTA  all      

References

n/a

 

Article # 3038590
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