PDFs processed through Document Conversion or Message Connector are producing different fonts
Issue
When processing a PDF through either the Document Conversion activity or the Message Connector, the fonts are being replaced with with non-originals.
Example:
Original
Converted
Cause
This case be caused if there are missing embedded fonts within the PDF itself. If the missing fonts are not installed on the Transformation Server machine(s) that process this job then this behavior is expected.
PDF specs state there are 14 "safe fonts". Example reference URL: https://kbpdfstudio.qoppa.com/standard-14-pdf-fonts/
You can run the suspect PDF through any PDF checker to see what Fonts are missing.
Solution
1. Embed the missing fonts into the PDF prior to KTA ingestion.
2. Install missing fonts onto Transformation server(s).
Level of Complexity
Moderate
Keywords: font, fonts, blurry, different
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
KTA | 7.10 |
References
Add any references to other internal or external articles