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System Error occurred. Please contact your System Administrator error using Federated Security

Article # 3049828 - Page views: 16

Issue

When attempting to sign into KTA utlizing Federated Security with Broadcom's Symantec SiteMinder iDP, the following error is encountered:

 

System Error occurred. Please contact your System Administrator

 

Cause

This may be caused by not enabling the Ignore RequestedAuthnContext option in the SiteMinder iDP settings.

 

This can be validated by checking the SAML response and checking for the following error:

<ns5:Response xmlns:ns5="urn:oasis:names:tc:SAML:2.0:protocol" xmlns:ns2="urn:oasis:names:tc:SAML:2.0:assertion" xmlns:ns4="http://www.w3.org/2001/04/xmlenc#" xmlns:ns3="http://www.w3.org/2000/09/xmldsig#" xmlns="http://www.w3.org/2009/xmlenc11#" ID="_46d1587e0d3392fa4b3cfe26577212xxxxxx" InResponseTo="_7e56d3f9-239f-46d3-93fb-c21374xxxxxx" Version="2.0" IssueInstant="2022-08-23T14:38:06.752Z">
    <ns2:Issuer Format="urn:oasis:names:tc:SAML:2.0:nameid-format:entity">dummy value</ns2:Issuer>
    <ns5:Status>
        <ns5:StatusCode Value="urn:oasis:names:tc:SAML:2.0:status:Responder">
            <ns5:StatusCode Value="urn:oasis:names:tc:SAML:2.0:status:RequestUnsupported"/>
        </ns5:StatusCode>
        <ns5:StatusMessage>The AuthnRequest with AuthnContexts is not supported!</ns5:StatusMessage>
    </ns5:Status>
</ns5:Response>

SAML response can be captured with many tools such as Fiddler or SAML-tracer.

 

Solution

Request for the SiteMinder iDP administrator to set Ignore RequestedAuthnContext to YES

 

Level of Complexity 

Moderate

 

Applies to  

Product Version Build Environment Hardware
KTA All      

References

Add any references to other internal or external articles

 

Article # 3049828