Skip to main content
Kofax

Upgrading a WEB server completes with no output on the summary screen

Article # 3042320 - Page views: 5

Issue

After upgrading a WEB server, no output is shown in the installation summary screen. Additionally, the KTA components still show the previous version in Programs and Features.

clipboard_e9f0c286993b87ffb7a5bacc3cc294831.png

clipboard_e941d13a20cf71a673bce551eaca4401f.png

 

Cause

A Process Monitor trace showed this behaviour was due to the fact the installation user did not have write permissions to the file Agility.Server.StreamingService.exe.config.

clipboard_e9bf97cc6e93e29f2d54ba5ef429bf33b.png

We'd expect the installation to have been completed with relevant errors being logged in the summary and the output log file. 

Note-Icon.png

NOTE: This is not specific to the Agility.Server.StreamingService.exe.config file thus lack of permissions to other files could yield the same behaviour.

 

Solution

The upgrade should be rolled back and the identified permission problem should be corrected.  The upgrade can be reattempted.

Alternatively, the old WEB server components can be uninstalled completely.  The new WEB server components can be then installed while pointing to the upgraded APP server.  This can be viewed as a "quick-fix" as reinstalling a WEB server requires very little configuration.

 

Level of Complexity 

Moderate

 

Applies to  

Product Version Build Environment Hardware
KTA 7.9      

 

Article # 3042320
  • Was this article helpful?