Upgrading a WEB server completes with no output on the summary screen
Issue
After upgrading a WEB server, no output is shown in the installation summary screen. Additionally, the KTA components still show the previous version in Programs and Features.
Cause
A Process Monitor trace showed this behaviour was due to the fact the installation user did not have write permissions to the file Agility.Server.StreamingService.exe.config.
We'd expect the installation to have been completed with relevant errors being logged in the summary and the output log file.
NOTE: This is not specific to the Agility.Server.StreamingService.exe.config file thus lack of permissions to other files could yield the same behaviour.
Solution
The upgrade should be rolled back and the identified permission problem should be corrected. The upgrade can be reattempted.
Alternatively, the old WEB server components can be uninstalled completely. The new WEB server components can be then installed while pointing to the upgraded APP server. This can be viewed as a "quick-fix" as reinstalling a WEB server requires very little configuration.
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
KTA | 7.9 |