KTM Server does not process Batches or opens a Batch and then just stops
Issue
Why might KTM Server not process Batches or opens a Batch and then just stops?
Cause
The Kofax Transformation Modules - Server Scheduler Service requires administrative privileges as well as network access to any paths used in the KTM project or the Kofax Capture configuration. The requirements are explained in detail in the KTM installation guide here.
Solution
Most problems with the Kofax Transformation Modules - Server Scheduler Service can be resolved by ensuring that the account running the service is a domain account with appropriate network permissions, as well as being added to the Local Administrators group on the machine(s) running KTM Server. Please note that when running the module, the service is still used and so this information is still applicable.
If KTM Server does not process Batches, or if it just opens a Batch and then stops, there will likely be errors reported in Capture\Local\Logs\ServerScheduler.txt.
Examples of these errors are below:
ExtractionProcessProxy | There was no endpoint listening at net.pipe://localhost/<GUID> that could accept the message. This is often caused by an incorrect address or SOAP action.
Could not connect to net.tcp://localhost:5000/SchedulerSessionPipe. The connection attempt lasted for a time span of 00:00:00.9844002. TCP error code 10061: No connection could be made because the target machine actively refused it 127.0.0.1:5000.
BatchProcessingProxy 1 | There was an error reading from the pipe: The pipe has been ended. (109, 0x6d). BatchProcessingProxy 1 | The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it is in the Faulted state.
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Kofax Transformation Module | all |
Article # 3035640