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Object Reference Not Set to an Instance of an Object Error Launching Express

Article # 3033045 - Page views: 1329

Issue

Launching Kofax Express results in the following error and the application crashes:

Object reference not set to an instance of an object

 

The Express logs report the following:

07-30-2019 13:49:12.926 Fatal: Source: Toolkit
Message: Object reference not set to an instance of an object.
Stack:    at Kofax.Eclipse.Toolkit.Licensing.KofaxLicenseManager.Open(Boolean bDongleInUse)
   at Kofax.Eclipse.Toolkit.ToolkitManager.InitializeLicenseAndRegistration()
   at Kofax.Eclipse.MainForm.MainForm.MainForm_Load(Object sender, EventArgs e)
07-30-2019 13:49:12.956 Application: Exiting all managers
07-30-2019 13:49:13.992 Application: All managers exited successfully
07-30-2019 13:49:14.611 Application: Exiting all managers finished successfully!
07-30-2019 13:49:14.687 Application: [SN21700037] [SN21700037\Kofax] Kofax Express(3.2.0.20.0.481) started.
07-30-2019 13:49:14.727 Fatal: Application crashed. Complete exception dump:
Source: System.Windows.Forms
Message: Cannot access a disposed object.
Object name: 'MainForm'.
Stack:    at System.Windows.Forms.Control.CreateHandle()

 

Cause

This issue can be caused by a corruption in the KofaxLicenseManager.xml file.

 

Solution

To resolve this issue:

1. Navigate to C:\ProgramData\Kofax\Kofax Express Licensing

2. Back up and delete the KofaxLicenseManager.xml file

3. Relaunch Kofax Express.  This will recreate the KofaxLicenseManager.xml file.

4. Reactivate the Kofax Express license.

 

Level of Complexity 

Easy

 

Applies to  

Product Version Build Environment Hardware
Kofax Express 3.2 ALL ALL N/A

References

N/A

 

Article # 3033045
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