Unable to Contact License Server Unexpected Error Occurred on Send Error Activating License
Article # 3032522 - Page views: 338
Issue
Attempts to activate a Kofax Express 3.2 license result in the following error:
9150 Unable to contact license server
The underlying connection was closed: An unexpected error occurred on a send.
Cause
Kofax Express 3.2 was written in .NET Framework 3.5 which only natively supports TLS 1.0. The Kofax licensing server no longer supports the older TLS 1.0 protocol used by .NET Framework 3.5.
Solution
.NET Framework 3.5 can be configured to use the TLS versions that are enabled in the Operating System. This allows Kofax Express to communicate with the licensing server using TLS 1.2.
To configure Kofax Express to communicate with the licensing server using TLS 1.2:
- Run
regedit.exe
- Navigate to
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v2.0.50727
- If one does not already exist, create a DWORD called
SystemDefaultTlsVersions
- Set the
SystemDefaultTlsVersions
value to1
- Navigate to
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v2.0.50727
- If one does not already exist, create a DWORD called
SystemDefaultTlsVersions
- Set the
SystemDefaultTlsVersions
value to1
- Navigate to
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols
- Create a new Key named
TLS 1.2
if one does not already exist
- In the
TLS 1.2
Key, create a subkey namedClient
- In the
Client
Key, create a DWORD (32-bit) Value namedDisabledByDefault
- Set the DisabledByDefault value to
0
- In the
Client
Key, create a DWORD (32-bit) Value namedEnabled
- Set the Enabled value to
1
- Reboot the machine
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Kofax Express | 3.2 | ALL | ALL | N/A |
References
N/A
Article # 3032522