Skip to main content
Kofax

Does VRS 5.1.x has an actual dependency on Virtual C++ 2008 Redistributable?

Article # 3032665 - Page views: 34

Article # 3032665 - Page views: 34

Issue

Does VRS 5.1.x has an actual dependency on Virtual C++ 2008 Redistributable?

 

Cause

VRS 5.1 and VRS 5.1.x are dependent on VC++ 2008.

Capture has deep integration with VRS. Therefore if VC2008 is completely removed from the system, VRS will not function.

If that happens, the following modules will not be able to use:
• Scan
• Recognition
• PDF Generator
• QC
• Export

Validation/Verification may work but RubberBand OCR will cause issue.

 

Solution

VRS 5.1, 5.1.1 (and might be 5.0 as well) were compiled against Visual Studio 2008 SP1, so “Virtual C++ 2008 SP1 Redistributable” version 9.0.30729.17 (or newer) is required.

Completely removal of VC++ 2008 Runtime Redistributable Dependency requires future version of VRS, cannot be applied with any of 5.0, 5.1, 5.1.1 versions even with an extensive code changes to these versions.
 

 

Level of Complexity 

Moderate

 

Applies to  

Product Version Build Environment Hardware
VRS 5.0, 5.1, 5.1.1      

References

Add any references to other internal or external articles

  • Was this article helpful?